Search found 181 matches

by ruperty
Thu Feb 08, 2018 11:54 am
Forum: EV3 Software
Topic: External Jar libraries on EV3
Replies: 7
Views: 912

Re: External Jar libraries on EV3

I have no trouble using external JARs by using the following setup (LeJOS 0.9.1 beta, Eclipse 4.5.2): 1. Added a simple project (General/project) called "LibraryProject" 2. Added the required JAR files to the LibraryProject 3. Added the required JAR to the build path of my LeJOS project u...
by ruperty
Thu Nov 09, 2017 6:17 pm
Forum: EV3 Hardware
Topic: Bus error
Replies: 1
Views: 132

Bus error

While running an EV3 I noticed a "bus error" and then the brick stopped responding. It also does not start up now. Beyond this screen it does not get, and no messages come up at the bottom as usual. http://www.perceptualrobots.com/wp-content/uploads/2017/11/2017-11-09-17.59.29.jpg A sd car...
by ruperty
Thu Sep 07, 2017 7:20 pm
Forum: EV3 Software
Topic: Motor angle fluctuation
Replies: 4
Views: 302

Re: Motor angle fluctuation

Here's the prototype using worm gears and perpendicular gearage.

https://youtu.be/ofN-VrVyKmM
by ruperty
Wed Aug 16, 2017 11:09 am
Forum: EV3 Projects
Topic: Robotics for the masses!
Replies: 3
Views: 362

Re: Robotics for the masses!

My crowdfunding project is now live ! I am offering free access to students, so if you are one message me directly and I'll add you to the list. I have some questions about your project: - What packages do you use on ROS? - How to integrate the Sensor/Actuator data on ROS? Hi Juan, Sorry just seen t...
by ruperty
Wed Aug 16, 2017 10:55 am
Forum: NXJ Hardware
Topic: NXT 2.0 brick dead
Replies: 1
Views: 241

NXT 2.0 brick dead

I have a NXT 2.0 brick which I didn't use for a year. When I then tried to turn it on there was no response from it whatsoever; no sounds or anything on the display. That was two years ago. I've just tried it again with normal batteries and the rechargeable battery, but still no response. I am assum...
by ruperty
Thu Aug 03, 2017 3:25 pm
Forum: EV3 Projects
Topic: Robotics for the masses!
Replies: 3
Views: 362

Robotics for the masses!

On August 15th 2017 I am launching on patreon.com to share my approach and software platform for developing goal-based robots. Currently the platform supports integration with LeJOS and ROS. I hope to grow a community of people interested in this way of controlling intelligent and adaptive robots wh...
by ruperty
Sat Jul 29, 2017 11:09 am
Forum: EV3 Software
Topic: Motor angle fluctuation
Replies: 4
Views: 302

Re: Motor angle fluctuation

Firstly there should be no need to send the rotateTo command multiple times. The regulator will hold the position if it possibly can. If it is not doing so then there are two possibilities either the motor has stalled trying to get to that position or if you are trying to hold a position that const...
by ruperty
Thu Jul 27, 2017 5:21 pm
Forum: EV3 Software
Topic: Motor angle fluctuation
Replies: 4
Views: 302

Motor angle fluctuation

I am trying to model a single leg standing up guided by an accelerometer value. As a test I am trying to hold the knee motor at a particular angle. It does hold it for a while, but then drops, as can be seen in this video , before returning to the angle position, within a few degrees. This repeats o...
by ruperty
Fri Jun 02, 2017 3:08 pm
Forum: EV3 Projects
Topic: Re-writing robotics
Replies: 1
Views: 313

Re-writing robotics

Hello, You may be interested in my robotics my paper just published in the Artificial Life journal (the architecture of which I implemented with lejos on NXT and EV3). " A General Architecture for Robotics Systems: A Perception-Based Approach to Artificial Life ", http://www.mitpressjourna...
by ruperty
Sat Mar 12, 2016 11:40 am
Forum: EV3 Projects
Topic: Robot on a train
Replies: 1
Views: 658

Robot on a train

Here's a little lejos robot than can stand up and balance by itself, on an day out on a train.
by ruperty
Mon Feb 08, 2016 9:35 am
Forum: EV3 Hardware
Topic: I2C I/O error
Replies: 4
Views: 1117

Re: I2C I/O error

I did have a delay of 25ms, though I see from the API that it suggests the delay should be > 30ms. That's 33 Hz. Is that right?

I'll try a delay of 35 ms.

I am using 0.9.1.
by ruperty
Sun Feb 07, 2016 11:41 pm
Forum: EV3 Hardware
Topic: I2C I/O error
Replies: 4
Views: 1117

I2C I/O error

I get this occasionally when a program has been running for a while. The NXTUltrasonicSensor is running in a separate thread. It doesn't coincide with the hanging issue I posted earlier so it may be a separate issue. In this case the program continues and the EV3 responds but the sensor value doesn'...
by ruperty
Sun Feb 07, 2016 1:21 pm
Forum: EV3 Software
Topic: EV3 stops responding
Replies: 2
Views: 1125

EV3 stops responding

I am finding a problem when an EV3 stops responding or executing a program after 10-30 minutes. At this point the program seems to hang or stop though the motors keep turning. Trying to connect over ssh it asks for the login and the password but the prompt doesn't appear. I am monitoring used memory...
by ruperty
Thu Dec 17, 2015 4:24 pm
Forum: EV3 Software
Topic: Wifi USB configuration
Replies: 3
Views: 675

Re: Wifi USB configuration

Did you happen to notice if the EV3 was displaying a WiFi address on the display after the reconfig? No, it wasn't. Oh and when you say nothing happened, did you watch the actual EV3 to see if anything was happening rather than the PC display? Yes, but the EV3 display didn't change. I was expecting...
by ruperty
Thu Dec 17, 2015 1:46 pm
Forum: EV3 Software
Topic: Wifi USB configuration
Replies: 3
Views: 675

Wifi USB configuration

I connected to my Ev3 with new sdcard by usb to configure wifi through ev3control.bat.

The list of access points came up and selected mine, which prompted for password, which I entered and clicked ok, but then nothing happened.

Should this be working? I had to configure directly on the Ev3 brick.

Go to advanced search