Enchanting cannot find Fantom drivers

This is the place to ask question about Enchanting, talk about your Enchanting projects or simply find out more about Enchanting on the NXT.

Moderator: clintonb

ggrinton
New User
Posts: 4
Joined: Wed Oct 29, 2014 10:05 am

Enchanting cannot find Fantom drivers

Postby ggrinton » Wed Oct 29, 2014 10:17 am

I have installed (upgraded to) Enchanting 0.2.4.3 on my Windows 7 64-bit computer, but when I try to run it, I get a message saying that I must "install LEGO's NXT driver", and then the program exits.

I have tried re-installing both the older Fantom drivers which were running fine with older versions of Enchanting, and also installed the new version which is referred to on the NXJ Software Forum. The result is the same in each case.

I have no problems running the regular Mindstorms software. or Bricx.

Any suggestions about what else I may need to do to get this version running please?

Thanks.
Geoffrey

clintonb
Active User
Posts: 137
Joined: Fri May 28, 2010 1:44 am
Location: Cardston, Alberta, Canada
Contact:

Re: Enchanting cannot find Fantom drivers

Postby clintonb » Tue Nov 04, 2014 1:47 pm

Hi Geoffrey.

Hmm... That's the first I've heard of this issue.

Enchanting includes a couple of tools, and they show up in the start menu. I think one is to flash the firmware and one it to browse files. Would you try them (without Enchanting running) and let me know if they work.

When you re-installed the older versions, could you tell if it actually worked? (Some installers refuse to install an old version on top of a new one. If fantom has an uninstaller, try it first). Looking through the forum, I get the sense LEGO has released a 64-bit version of the Fantom driver, and I'll bet it doesn't work with Enchanting : (

Cheers,
Clinton Blackmore

joezzhou
New User
Posts: 1
Joined: Thu Mar 17, 2016 3:01 am

Re: Enchanting cannot find Fantom drivers

Postby joezzhou » Thu Mar 17, 2016 3:10 am

I tried to run enchanting 0.2.4.3 on windows 10 x64 machine and got the following error:
Enchanting is unable to start: you need to install LEGO's NXT driver before you can run Enchanting.
However I have installed LEGO Phanton Driver downloaded from the Enchanting web site.
I installed the driver before installing the Enchanting.

Also tried the same on a windows 7 machine, got the same error.

Do not know how to solve this problem. HELP?

Thanks.


Return to “Enchanting Questions and Projects”

Who is online

Users browsing this forum: No registered users and 1 guest