leJOS installer stuck

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

Pocketkid2
New User
Posts: 13
Joined: Wed Apr 08, 2015 6:06 pm

leJOS installer stuck

Postby Pocketkid2 » Wed Apr 08, 2015 6:12 pm

I'v just bought a brand new SD card that has 32 GB. I've cleared it, formatted it to be FAT32, and I created the disk image using the sdcard tool. I stuck it in the EV3, booted it up, and it started installing. When it gets to the step Installing rootfs, it gets stuck and doesn't advance. I've waited 20+ minutes, with no luck. I've also tried doing the whole process again. What could be going on?

User avatar
gloomyandy
leJOS Team Member
Posts: 5969
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: leJOS installer stuck

Postby gloomyandy » Wed Apr 08, 2015 6:27 pm

No idea sorry, reformat and try again. If it still does not work get another SD card (you don't need a large one, there is no advantage to having 32Gb) and try that.
leJOS news https://lejosnews.wordpress.com/

Pocketkid2
New User
Posts: 13
Joined: Wed Apr 08, 2015 6:06 pm

Re: leJOS installer stuck

Postby Pocketkid2 » Wed Apr 08, 2015 6:38 pm

I've already tried reformatting using the windows one. Does it matter the size? I'm using a micro SD HC, shouldn't that work? This is really annoying...

User avatar
gloomyandy
leJOS Team Member
Posts: 5969
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: leJOS installer stuck

Postby gloomyandy » Wed Apr 08, 2015 6:58 pm

Search the forum you will find lots of people that have had similar problems that go away when they use a different sd card. If you look at the raspberry pi forums you will see the same story. Unfortunately there are a lot of counterfeit cards on the market, so even if you think you have a high quality card it may not be what it appears. I always recommend the use of the following program to format the card:
https://www.sdcard.org/downloads/formatter_4/
But really with a new card it is best to just try it first.
leJOS news https://lejosnews.wordpress.com/

Pocketkid2
New User
Posts: 13
Joined: Wed Apr 08, 2015 6:06 pm

Re: leJOS installer stuck

Postby Pocketkid2 » Wed Apr 08, 2015 7:40 pm


User avatar
gloomyandy
leJOS Team Member
Posts: 5969
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: leJOS installer stuck

Postby gloomyandy » Wed Apr 08, 2015 8:17 pm

Looks like it should be ok. But SD cards can be very odd, they sometimes have hidden partitions that cause problems or have special features that may only work with a Windows style file system.

If reformatting with the tool I suggested does not work then you could try writing the sd500.img file to the disk (using an image writing tool search the web for details, here is a starting point http://blogs.arcsoftwareconsultancy.com ... h-windows/) and then using that. But if you do decide to try this be very careful and make sure you select the correct output drive.

As I said you don't need a large SD card for leJOS 1GB is more than enough, so no need to buy an expensive card.
leJOS news https://lejosnews.wordpress.com/

Pocketkid2
New User
Posts: 13
Joined: Wed Apr 08, 2015 6:06 pm

Re: leJOS installer stuck

Postby Pocketkid2 » Thu Apr 09, 2015 5:41 pm

I think I've finally fixed it! For anyone who has a similar problem, the only thing that worked in the end was figuring out how to write sd500.img to the SD card. It didn't seem like it would make much of a difference, and it also took me quite a while to figure out how to do it right, but once I did, then it started working.

Thanks for all the help!

scarybiscuits
New User
Posts: 2
Joined: Mon Dec 25, 2017 5:17 pm

Re: leJOS installer stuck

Postby scarybiscuits » Mon Dec 25, 2017 5:27 pm

Hi folks,

I'm having the same problem where the install gets stuck. I have tried cleaning the SD card with DiskPart and reformatting to FAT32, and - when that didn't work - tried using the SD Card formatter in a previous thread. Still no joy. I really don't want to have to buy another blood SD card as also suggested above, is there a step-by-step guide for creating an sd500.img file somewhere? Any help would be greatly appreciated.

ta,

User avatar
gloomyandy
leJOS Team Member
Posts: 5969
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: leJOS installer stuck

Postby gloomyandy » Tue Dec 26, 2017 8:53 am

The sd500.img is a file that is included with the lejos download. You then just need to use an img writer program (like those used to copy a linux system image to an sd card), to copy the file to the sd card using raw writes.

But if you are having all these problems there is a good chance that the sd card you have will cause problems later. get a smallish (8Gb), slowish one. Avoid anything fancy, large or high speed.
leJOS news https://lejosnews.wordpress.com/

scarybiscuits
New User
Posts: 2
Joined: Mon Dec 25, 2017 5:17 pm

Re: leJOS installer stuck

Postby scarybiscuits » Sun Dec 31, 2017 1:46 pm

Hi gloomyandy - cool name btw - thanks for your reply, but I kind of sorted it myself.

Basically you were dead right, it was the size of the SD card that was causing the issue. So I tried putting a 4GB partition on it and installed the software there. Booted straight away, with no issues since. Thanks again for your help though :D


Return to “EV3 Software”

Who is online

Users browsing this forum: No registered users and 5 guests