USB connection activation failed Ubuntu 17.04

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

kak3n
New User
Posts: 9
Joined: Sat Jun 20, 2015 8:12 pm

USB connection activation failed Ubuntu 17.04

Postby kak3n » Wed Jul 05, 2017 8:58 am

On my old laptop I got working connection via usb by following this tutorial. But on my new laptop I get this error. Image

Thanks for answer.
Lejos version 9.1
Ubuntu 17.04 x64
Lejos is in pan configured as usb client all settings are on auto and persistent no.

User avatar
gloomyandy
leJOS Team Member
Posts: 5899
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: USB connection activation failed Ubuntu 17.04

Postby gloomyandy » Wed Jul 05, 2017 9:17 am

Why are you following instructions for ev3dev when trying to use leJOS?

To connect to leJOS using USB, just configure the EV3 as an access point, then plug the device into your LInux system, you should see a new network connection, it may just work, if not configure the connection to use DHCP to obtain the settings and try again. Your EV3 will have address 10.0.1.1
leJOS news https://lejosnews.wordpress.com/

kak3n
New User
Posts: 9
Joined: Sat Jun 20, 2015 8:12 pm

Re: USB connection activation failed Ubuntu 17.04

Postby kak3n » Wed Jul 05, 2017 10:14 am

gloomyandy wrote:Why are you following instructions for ev3dev when trying to use leJOS?

To connect to leJOS using USB, just configure the EV3 as an access point, then plug the device into your LInux system, you should see a new network connection, it may just work, if not configure the connection to use DHCP to obtain the settings and try again. Your EV3 will have address 10.0.1.1

Thanks using DHCP and setting it as access point solved the problem.


Return to “EV3 Software”

Who is online

Users browsing this forum: No registered users and 1 guest