No brick found when connected via USB

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

New User
Posts: 1
Joined: Thu Oct 26, 2017 3:27 pm

No brick found when connected via USB

Postby Rezoan » Thu Oct 26, 2017 4:24 pm

Hi guys! I'm a completely new Lejos programmer, and I'm making a lejos program in order to come up with a solution for a problem at school. We have to create a robot that navigates through a maze. Anyways... thats not important. The thing is, when I try to run the program, it creates the JAR file and everything, but it does not find any brick. This happens with both eclipse and intellij. In fact, I get the exact same error message when I have it plugged in via USB, as when I do not have it plugged in at all. I've tried to google a solution, and I found that I have to install RNDIS/ethernet adapter or something, but I can't find anywhere to download that driver. I'm using windows 10, eclipse oxygen, the latest plug-in as of 5 minutes ago, and java 9.0.1 on the EV3 brick. I know this is probably a really noob question, but please show some mercy :D
error message:

Jar file has been created successfully
Using scp for upload and ssh to execute program
Uploading to ...
EV3ScpUpload: Failed to upload or run jar file: com.jcraft.jsch.JSchException: Connection timed out: connect
Starting EV3ScpUpload failed with exit status 1
leJOS EV3 plugin launch complete

Return to “EV3 Software”

Who is online

Users browsing this forum: Google [Bot] and 1 guest