Computer doesn't see EV3 via USB nor via Bluetooth

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

User avatar
ProHacker
New User
Posts: 24
Joined: Mon Dec 25, 2017 8:50 am
Location: Russia

Computer doesn't see EV3 via USB nor via Bluetooth

Postby ProHacker » Mon Dec 25, 2017 4:41 pm

Hello, guys!
I use leJOS EV3 for 1st time and got a problem: my computer doesn't see EV3 via USB nor via Bluetooth. I read some posts on this forum, disabled my firewall, switched on ssh-mode and entered correct IP (10.0.1.1). But it doesn't work! :cry: Please, help me!
Thank you for answer!
LeJOS rules! :D

User avatar
jippiee
New User
Posts: 11
Joined: Tue Dec 26, 2017 1:07 am

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby jippiee » Tue Dec 26, 2017 1:33 am

Hi,
I had the same issue the first time I used leJOS. The simple fix I found was that you have to connect the EV3 via USB while it's still off. Then during startup it should load the drivers or buildup the connection (I also don't know what happens inside). So when it's fully booted up there is a connection established between the EV3 and the PC. The same thing also applies for a wifi-dongle.

User avatar
gloomyandy
leJOS Team Member
Posts: 6022
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby gloomyandy » Tue Dec 26, 2017 8:56 am

How are you trying to connect via Bluetooth? You need to pair the two devices and then once paired you need to go to the the device seen on your computer and choose connect to access point to connect the two using a network connection.

But having said all of that I would strongly suggest that if you have a local WiFi network you spend and extra £5 and get a WiFi dongle and use that. Things are much easier and faster using WiFi.
leJOS news https://lejosnews.wordpress.com/

User avatar
ProHacker
New User
Posts: 24
Joined: Mon Dec 25, 2017 8:50 am
Location: Russia

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby ProHacker » Tue Dec 26, 2017 2:27 pm

I'll check... Thank you very much!
LeJOS rules! :D

User avatar
ProHacker
New User
Posts: 24
Joined: Mon Dec 25, 2017 8:50 am
Location: Russia

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby ProHacker » Tue Dec 26, 2017 2:53 pm

Sorry, guys! Your methods don't work.
Compilation log:
Jar file has been created successfully
Using the EV3 menu for upload and to execute program
IP address is /10.0.1.1
Creating the jar file or uploading the program failed
java.rmi.ConnectException: Connection refused to host: 10.0.1.1; nested exception is:
java.net.ConnectException: Connection timed out: connect
Caused by java.net.ConnectException: Connection timed out: connect
See Eclipse error log for detailed stack trace.
LeJOS rules! :D

User avatar
gloomyandy
leJOS Team Member
Posts: 6022
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby gloomyandy » Tue Dec 26, 2017 6:00 pm

You must have the EV3 Bluetooth turned, you must also have the EV3 PAN settings set to Access point (with everything else left as is, this is the default state of leJOS), you must then pair your computer with the EV3? Have you then connected your PC to the PAN Access point that is created by the EV3? Bluetooth will not work unless you do all of these. See:
https://sourceforge.net/p/lejos/wiki/Co ... oth%20PAN/
Unfortunately Microsoft seem to change the exact way you do this pretty much every time they update Windows, so you may need to adapt the various steps. Many, many people have had this working fine, so if it isn't working for you then something very odd is going off.

For USB you will need to have the correct driver installed to support networking over USB. Some windows systems seem to have problems with setting this up automatically you will need an RNDIS driver. There are many threads on this forum about this.
leJOS news https://lejosnews.wordpress.com/

User avatar
ProHacker
New User
Posts: 24
Joined: Mon Dec 25, 2017 8:50 am
Location: Russia

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby ProHacker » Wed Dec 27, 2017 4:33 pm

BUT THIS DOESN'T WORK TOO!
LeJOS rules! :D

User avatar
gloomyandy
leJOS Team Member
Posts: 6022
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby gloomyandy » Wed Dec 27, 2017 5:55 pm

If you want to get any help you need to provide a lot more detail than "it doesn't work". Because guess what it works fine for me and for many. many others. So something about what you have or what you are doing must be different to what all of those other people have, or have done. So you need to provide details of exactly what you have done and what happens, so far you have provided nothing of any use. Simply posting the results of trying to connect is no use at all. You need to give details of how you have got to that state...
What version of leJOS do you have on the EV3
What settings do you have for the EV3 PAN mode
What Bluetooth adaptor you have on your computer and what Bluetooth stack you are using
How did you pair your EV3 with your computer did it work? How do you know?
How did you establish the PAN from the computer to the EV3, did it work how do you know?

You haven't even told us what sort of computer and operating system you are using, nor the version of leJOS you have installed.
leJOS news https://lejosnews.wordpress.com/

User avatar
ProHacker
New User
Posts: 24
Joined: Mon Dec 25, 2017 8:50 am
Location: Russia

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby ProHacker » Thu Dec 28, 2017 5:20 pm

I would say if compilation error change. But it's same with recent one.
leJOS version is: 0.9.1-beta
EV3 IP address: 10.0.1.1
JRE version is the last.
OS: Windows Pro 64-bit
Eclipce: 64-bit.
I can't connect to EV3 Bluetooth PAN.
Other questions: where I can get info about my Bluetooth adapter?
LeJOS rules! :D

User avatar
gloomyandy
leJOS Team Member
Posts: 6022
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby gloomyandy » Thu Dec 28, 2017 7:09 pm

You have still not provided any details as to how you are pairing the two Bluetooth devices, or how you are attempting to establish the PAN and what happens when you do, nor have you provided any details as what version of Windows (7? 8? 10?) or which version of eclipse you are using (64 bit is not a version number for eclipse). You need to provide a detailed description of exactly what steps you have taken to pair the two devices (along with any messages you get) and what steps you are taking to establish the PAN. Take a video of the steps you are taking and post a link to it. I've already posted a link which shows you how to do this with Windows 7, have you followed those instructions?
https://sourceforge.net/p/lejos/wiki/Co ... oth%20PAN/

If the PAN has been established you should be able to ping the address of the EV3 10.0.1.1 can you do this? If there is no PAN or you are unable to ping 10.0.1.1 then you will not be able to upload or connect from within eclipse, you need to have the PAN established first.

If none of this makes any sense then you either need to try using a WiFi dongle (assuming you have WiFi available to you), or perhaps leJOS is not for you.
leJOS news https://lejosnews.wordpress.com/

User avatar
ProHacker
New User
Posts: 24
Joined: Mon Dec 25, 2017 8:50 am
Location: Russia

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby ProHacker » Fri Dec 29, 2017 7:33 am

Oops. I forgot about Windows, it's 10 Pro 64-bit. Also I've pared EV3 with computer like in that instruction.
LeJOS rules! :D

User avatar
ProHacker
New User
Posts: 24
Joined: Mon Dec 25, 2017 8:50 am
Location: Russia

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby ProHacker » Fri Dec 29, 2017 10:00 am

Hello, there!
I searched on this forum and found a link: http://www.aplu.ch/home/ev3_inst.html. It is very helpful!
I installed the driver, and programs are uploading!
But I have a new executing problem, new theme link: viewtopic.php?f=18&t=9085
Thanks for help! :D
Last edited by ProHacker on Fri Dec 29, 2017 10:26 am, edited 1 time in total.
LeJOS rules! :D

User avatar
gloomyandy
leJOS Team Member
Posts: 6022
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Computer doesn't see EV3 via USB nor via Bluetooth

Postby gloomyandy » Fri Dec 29, 2017 10:22 am

If you are using Bluetooth, you need to do more than just pairing. Once paired you need to connect to the PAN access point (which is the EV3) as shown in the link you provided. The way you do this is different (but similar) for each version of Windows, if you do not connect to the PAN Bluetooth connections will not work. Did you try to connect to the access point. You can check to see if you have a connection by pinging the EV3 (ping 10.0.1.1). You will need to reconnect to the PAN if you ever reboot your PC or EV3.

If you are building mobile robots then using Bluetooth or better still WiFi is much, much easier then using USB.
leJOS news https://lejosnews.wordpress.com/


Return to “EV3 Software”

Who is online

Users browsing this forum: No registered users and 1 guest