Lejos intaller

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

gerardit4
New User
Posts: 4
Joined: Mon Apr 30, 2018 7:58 pm

Lejos intaller

Postby gerardit4 » Mon Apr 30, 2018 8:00 pm

When leJOS is installing in the EV3 brick says this error: Java not installed

What I need to do?

User avatar
gloomyandy
leJOS Team Member
Posts: 6047
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Lejos intaller

Postby gloomyandy » Mon Apr 30, 2018 10:03 pm

You need to have installed a jre for the EV3. See:
https://sourceforge.net/p/lejos/wiki/Wi ... tallation/

Take careful note of the instructions for creating the sd card. You must use the Jave 7 JRE download from Oracle, do not try and use the Java 8 SDK (or any other) unless you really, really understand what you are doing (and since you are asking this question, you probably don't :-)).
leJOS news https://lejosnews.wordpress.com/

gerardit4
New User
Posts: 4
Joined: Mon Apr 30, 2018 7:58 pm

Re: Lejos intaller

Postby gerardit4 » Tue May 01, 2018 7:59 am

I can't download it says that it isn't aviable

User avatar
gloomyandy
leJOS Team Member
Posts: 6047
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Lejos intaller

Postby gloomyandy » Tue May 01, 2018 9:05 am

What exactly does it say, post a screen shot of the error. Did you agree to the license? Do you have an Oracle account (you will be asked to create one if you don't)? All works fine for me and many, many other people. I've just tried it and it worked fine, try it again.
http://www.oracle.com/technetwork/java/ ... 82511.html
leJOS news https://lejosnews.wordpress.com/

gerardit4
New User
Posts: 4
Joined: Mon Apr 30, 2018 7:58 pm

Re: Lejos intaller

Postby gerardit4 » Tue May 01, 2018 9:22 am

now when finish the installation the screen stops like this the logo of lejos and EV3 and don't respond

User avatar
gloomyandy
leJOS Team Member
Posts: 6047
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Lejos intaller

Postby gloomyandy » Tue May 01, 2018 9:41 am

Spend some time browsing the forum, you will see that others have had this problem, usually a problem with the sd card. See those other threads for how to fix the problem. Start all over again, reformat the sd card and do the sd card install from scratch. If it does not work try a different sd card. Browse the forum for similar threads. I am not aware of any actual problem if you use a suitable sd card and follow the instructions. There are many, many dodgy sd cards out there that can be a problem, so reformat, and if that does not work try a different one, you don't need anything fancy or fast.
leJOS news https://lejosnews.wordpress.com/

User avatar
gloomyandy
leJOS Team Member
Posts: 6047
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Lejos intaller

Postby gloomyandy » Tue May 01, 2018 9:44 am

leJOS news https://lejosnews.wordpress.com/


Return to “EV3 Software”

Who is online

Users browsing this forum: No registered users and 1 guest