Full loss of motor control after installation

This is where you talk about the NXJ hardware related topics such as the brick, sensors, LEGO pieces, etc.

Moderators: imaqine, 99jonathan, roger

New User
Posts: 2
Joined: Tue Feb 06, 2018 5:08 pm

Full loss of motor control after installation

Postby tobi1702 » Sat Feb 10, 2018 3:52 pm

Hello everyone,
I'm in a rather dire situation:

I did all the installation routines of lejos according to the tutorial, and it can display stuff, read buttons etc. But I don't have any motor control. Furthermore, when I flashed back to the LEGO NXT System, it still didn't work, even though it had worked befor I did the installation! And I tried it ion a friends Mindstorms, and the same thing happened! How can that be? And, more importantly, how can I fix it?

User avatar
leJOS Team Member
Posts: 6054
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Full loss of motor control after installation

Postby gloomyandy » Sat Feb 10, 2018 8:21 pm

Are you sure that the problem is not with your motors or cables? There have been no other reports of this type with leJOS and it seems strange that you have managed to to whatever it is you have done to two NXTs! I also note from your earlier post that you had some sort of motor control issue earlier, but the motors still worked to some degree. Things to check...

1. Make sure you have new batteries (or fully charged ones).
2. Try different motors
3. Try different cables.
4. Reflash the LEGO firmware and try everything again.

I doubt very much if this is a leJOS problem, but I would advise that you do not try any more NXTs!
leJOS news https://lejosnews.wordpress.com/

Return to “NXJ Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest