NXJ is ticking and can't power on

This is where you talk about the NXJ hardware related topics such as the brick, sensors, LEGO pieces, etc.

Moderators: imaqine, 99jonathan, roger

Active User
Posts: 130
Joined: Tue Jul 20, 2010 2:01 pm

Postby s.frings » Tue Jul 20, 2010 2:22 pm

The Mindstorms device does not call itself "GPS Camera". So if your operating system shows that name, the bluetooth settings of Windows are obvisouly broken. I would try to reinstall Windows or use another computer and then retry.

New User
Posts: 1
Joined: Wed Oct 27, 2010 6:16 am

Mine ticking as well...

Postby Orthopteroid » Wed Oct 27, 2010 6:24 am

I think my NXT is hosed, yours may be too if you have all the following symptoms:

- you plug it into windows and the device driver recognizes a 'new' device 'GPS Camera Detect' product that is made by 'Wonde Proud'.
- you plug it into linux and using the command 'lsusb' you see a new device 'Atmel Corp. at91sam SAMBA bootloader'.
- youve tried libnxt's fwflash utility in linux to no avail.
- youve tried the sam-ba_cdc_2.8.linux_01 utility in linux to no avail.

Anyone else have other (linux or windows) favorite utilities to flash the firmware?

User avatar
leJOS Team Member
Posts: 6017
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Postby gloomyandy » Wed Oct 27, 2010 7:30 am

Hmmm that does not sound good. However the device is showing up correctly on Linux, so I'm surprised that you are not able to flash it from there. Have you ever been able to flash the device from your linux system? If not perhaps you just need to adjust some of the settings. On Windows do you have the Lego drivers installed? Can you find and delete (or at least disable) the camera driver that is being recognised and then try again....

leJOS Team Member
Posts: 1550
Joined: Thu Oct 30, 2008 4:54 pm

Postby skoehler » Wed Oct 27, 2010 8:49 am

s.frings wrote:The Mindstorms device does not call itself "GPS Camera". So if your operating system shows that name, the bluetooth settings of Windows are obvisouly broken. I would try to reinstall Windows or use another computer and then retry.

That one time, I chose "search for drivers online" and windows downloaded some drivers from windows update. After that, the NXT was called "GPS something" - maybe it was that camera too.

Update: I can confirm this! Today, I bootet my old Windows 7 installation which detected the NXT (in firmware update mode) as "GPS Camera Detect (COM12)".

I would recommend, that the person who has the problem installs the Lego drivers. You then may have to right click the device in the device manager, then chose "update driver" and switch to the lego drivers manually.

With the wrong drivers, you wont be able to flash the device.

The even better method is to install the Lego drivers before you connect the NXT for the first time.

Posts: 41
Joined: Mon Jun 28, 2010 4:04 pm
Location: Jakarta

Postby shinjiyuubix » Sat Oct 30, 2010 6:55 am

Hi all

Have all of you tried on linux?
Salam super from Jakarta 8)

New User
Posts: 8
Joined: Sun Mar 21, 2010 3:17 pm

Finally made it

Postby Evertjelle » Wed Nov 10, 2010 4:17 pm

hello, im back! :p the reason is this:
I finally repared my nxt :D :D :D :D :D :D :D :D !!!!!!!!! I never was so happy to hear that startup sound again!!!!!!!!

═════Here is how i did it:════════════════════════════════════════════════════════

-done with Windows 7 32 bit Ultimate
-also using NXT-G 1.0
-installed all the drivers i could need for this (download here)

My NXT is ticking after i tried to install LeJos Firmware. If i plugged the NXT in my computer via a usb cable, my computer named him 'GPS Camera' or something. Whatever i do, nothing happened, just stays ticking. If i hold down the button on the back in the upper-left corner, he stops ticking for a while, then gives a loud click, and continues ticking. The only way to stop the ticking is putting the batteries out of it.

my Solution
First, Download the latest NXT firmware here.
Copy the file inside the zip to your desktop.

Then, plug your NXT in your computer using a USB cable.
Wait until your computer recognises him, then go to your 'Devices' or something. Right-Click your NXT ('GPS Camera' or something) and select properties. then go to the tab hardware, and click again 'Properties'.

Then select tab 'Driver' and click the second button ('Update').

Next click the second button (NOT automaticly search or something, but search on your computer). Then click again the second button. Select something with '61883' in it, and click Next.

After that, DEselect the option 'Compatible hardware' or something. If its right there have to appear 'LEGO MINDSTORMS NXT'. Select that, and click Next. If he asks something, click yes.

Then you should get a screen that indicates that it has succeeded.

Then startup NXT-G and select from the menu 'extra' and then 'Update Firmware' or something. Select the firmware version you just downloaded and click download. Normally, you should hear the NXT startup sound.

For me it worked, i hope for you too.


PS: the or something things are there because i dont know what it is English, i am dutch and i have dutch Windows and NXT-G.

New User
Posts: 1
Joined: Sat Dec 12, 2015 10:18 pm

Re: NXJ is ticking and can't power on

Postby unmodify@yahoo.com » Sat Dec 12, 2015 10:24 pm

This absolutely worked for me too! The trick is the name of the device in device manager will be "something" in my case it was a new (com5) port. I found it by plugging and unplugging the ticking brick. After doing the update driver method and follow the rest of his instructions I then used the lego software to reflash it and it worked!

You sir I am grateful to. Very good detective work. I had just gotten a brick and this happened, I was pretty bummed...but now we got it working.

Man, thank you!

Return to “NXJ Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest