Problem after firmware upgrade [SOLVED]

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: imaqine, 99jonathan, roger

New User
Posts: 5
Joined: Mon Jul 02, 2007 10:32 pm

Problem after firmware upgrade [SOLVED]

Postby muimui » Sun Jul 15, 2007 5:26 am

I believe I have successfully upgraded the firmware. I executed "lejosdl Tune.bin" and I did hear a tune play. However, after the tune play, the NXT kept on audibly clicking, with nothing shown on the screen. Press the orange button or the orange+grey buttons together have no effect. The NXT is still keep on audibly clicking even after I removed and replaced the battery.
Any idea what had happened? Thanks

leJOS Team Member
Posts: 965
Joined: Mon Feb 05, 2007 1:27 pm

Postby lawrie » Sun Jul 15, 2007 3:59 pm

This is how release 0.2alpha works. It runs programs in RAM and returns to the SAMBA boot monitor when it finishes. This is what ticks. You do lejosdl with another .bin file to run another program.

Release 0.3.0alpha is out to today and this is a proper persistent flash firmware version - try it. Read the README.html file as it is a lot different to the 0.2alpha release.

New User
Posts: 1
Joined: Thu Dec 20, 2007 4:33 am
Location: Tokyo, Japan.

[Patch] The device initialize on boot process.

Postby monaka » Thu Dec 20, 2007 4:57 am

I'm trying Lejos/OSEK and encountered similar issue.

This is a patch to fix the issue.
SAMBA is not initialize CPU's peripherals on go command.
Could someone apply this patch to svn repository ?

+++ init.s (local)
@@ -47,6 +47,19 @@
mrs r0,cpsr
orr r0,r0,#0xc0
msr cpsr_all,r0
+@ patch begin
+ ldr r0, =0xfffffd00
+ ldr r1, [r0, #4] @ RSTC_SR
+ ands r1, r1, #0x20000
+ bne 0b
+ ldr r1, =0xa5000004
+ ldr r1, [r0] @ RSTC_CR
+ ldr r1, [r0, #4] @ RSTC_SR
+ ands r1, r1, #0x20000
+ bne 1b
+@ patch end

Return to “NXJ Software”

Who is online

Users browsing this forum: No registered users and 1 guest