Page 1 of 1

libusb0.dll not found

Posted: Sat Jul 21, 2007 5:41 pm
by dwinton
When I tried to flash the firmware to the NXT brick, I typed in nxjflash and got a pop-up to the effect of libusb0.dll not found, reinstall. I am not sure what this means.

nxjc says javac is not recognized as a command etc. even though I have been using java for years.

Posted: Sat Jul 21, 2007 9:30 pm
by lawrie
You need to install the libusb-win32 filter driver as it says in the README.html file.

If you get a message saying javac is not recognized as a command, then the bin directory of the Java SDK is not on your path. Type PATH to check your path.

Posted: Sun Jul 22, 2007 2:48 pm
by dwinton
But the the java directory clearly is as I have been compiling stuff with eclipse for months and with JCreator for about a year.

Do I need the Filter driver and the device driver? Why didn't my book tell me about this? So far, my book has been very misleading (told me to make LEJOS_HOME rather than NXJ_HOME for one).

New Problem. It has been a day since it entered firmware upload mode. Now that the issues seem to be resolved, I get a no NXT found error.

Posted: Mon Jul 23, 2007 12:15 pm
by imaqine
For issues with things written in the book go to

Look for the Revised Installation Instructions for the Book post.

Posted: Mon Jul 23, 2007 12:16 pm
by lethalwire
To fix my "NXT not found error", I downloaded the libusb-win32-filter-bin.

Posted: Mon Jul 23, 2007 5:15 pm
by dwinton
I have that, I still have the problem. I am afraid my brick isn't in upload mode any longer

Posted: Tue Jul 24, 2007 3:28 am
by bbagnall
I'm not entirely clear what problem you are having now, but it sounds like you aren't hearing a soft pulse anymore? That might mean the firmware is now uploaded, if you see battery level at the top of the LCD.

Or maybe you need to insert the paper clip again to put it back into firmware upload mode?

Posted: Wed Jul 25, 2007 2:21 pm
by dwinton
No battery thing. I put the paperclip in and nothing happens.

Posted: Wed Jul 25, 2007 2:51 pm
by imaqine
You have to insert paperclip for about four seconds then you will hear a very faint audible clicking noise. This means if is in firmware upload mode. I had a very hard time hearing this noise. You should put the birck up to your ear to verify if it worked.

Posted: Thu Jul 26, 2007 12:14 pm
by dwinton
Dude, I did that the first time. That is how the normal lego firmware got deleted. It isn't buzzing anymore though and the peperclip trick doesn't seem to work.

I fixed it...with magic. I opened the nxt brick and found one of the things that should have been connected to the battery not connected any longer. Broken circuit yields no power

New problem though my NXJ_HOME value is C:\Program Files\Java\lejos_nxj. When I type nxj (anything here) I get:
C:\Program Files\Java\lejos_nxj\samples\Tune>nxj -r Tune
Exception in thread "main" java.lang.NoClassDefFoundError: Files\Java\lejos_nxj\

Posted: Thu Jul 26, 2007 12:31 pm
by imaqine
lol I'm glad that worked out for you. I wonder how whatever inside the brick got disconnected.

Posted: Sun Jul 29, 2007 9:19 pm
by lawrie
There is a current restriction that the nxj commands do not work if lejOS NXJ is installed in a folder with spaces in the name
(such as "Program Files"). Move it to a folder with no spaces in the name.

NXT not found

Posted: Fri Aug 10, 2007 2:34 am
by RandyBrown
Brian and/or others,

I downloaded the latest lejos version 0.3 yesterday and have followed the updated instructions for flashing nxj firmware. I set up the path correctly so that when I type nxjflash from the command prompt some things are happening. I get a "checking VM ... ok checking memory... ok...

But then I get the line "NXT not found.. is it properly plugged in?"

I installed the linusb program, but somehow the usb isnt recognizing the nxt when it is in the firmware upload mode???
It looks like others have come across this issue... suggestions?



Posted: Thu Aug 16, 2007 1:45 am
by RandyBrown
OK.. I have finally figured this out.
If you use a paperclip and clear the nxt brick (placing it in that pulsing mode) and then install libusb on the Program Files folder, and then attempt to flash the nxt with lejos you will get the "nxt not found" message. IF you then move the libusb to a folder that has a name with no spaces in it and attempt to flash lejos again you will still get the "nxt not found" message. In order to get lejos onto the brick you need to get a paper clip and hold down that little button on the brick to reset it AGAIN, even though it is already in that pulsing mode. In short, libusb needs to be in an appropriate location BEFORE you attempt to flash the brick with lejos.

Posted: Mon Aug 20, 2007 5:32 pm
by bbagnall
Thanks, Randy. That's something we never tried so we weren't aware of it.