Vista with libusb-Win32 - Working!

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: imaqine, 99jonathan, roger

User avatar
Site Admin
Posts: 392
Joined: Fri Aug 04, 2006 4:03 pm

Vista with libusb-Win32 - Working!

Postby bbagnall » Sun Oct 28, 2007 10:42 pm

Is there someone with Vista who could give libusb-win32 a try with these instructions? There's apparently a problem where it will uninstall USB devices when you install libusb, but this might work (copied and pasted from libusb-Win32 Sourceforge forum):

EDIT: Before trying these instructions, make sure the LEGO NXT drivers are installed and the brick is recognizable before installing libusb WIN32 filter. With NXT only on usb (should be under Device Manager/LEGO Devices), run TestLibUsb. If 03EB/6124 shows-up you are good to go.

EDIT: You only need to do steps 1-3 and it should work.

Installing LibUsb-Win32 on Vista

1.Download libusb-win32-filter-bin- (the version current @ 27/09/07)

2.Right click on this file. Select Properties | Compatibility Click the “Run this program in compatibility mode” box and select “Windows XP (Service Pack2)” from the drop down list.

3.Right click again and select “Run as “Administrator”. Follow the installation instructions. Run the test program will list the usb devices plugged into your computer – but not new devices.

4. Go to a downloaded and expanded folder
Plug in new usb device and create a .inf file by going to the /bin
folder and double-clicking inf-wizard.exe

5. Follow the instructions. The program suggested I save the files in
Alex/Documents so I left them there. It saved a .inf file and 2
.cab files.

6. From the Vista start button, go to Control Panel | Device
Manager. This shows my device under “Other devices”. Clicking on
the device gives me the properties and tells me that there is no
driver installed. Click Reinstall Driver. Browse my computer for
driver software. Browse to Alex/Documents then click Next. I then
get the messages:-

Windows found driver software for your device but encountered an
error while attempting to install it.

The system cannot find the file specified.

7. On inspecting the directories, I have Windows/System32/libusb0.dll
and Windows/System32/Drivers/libusb0.sys. I have noticed that on
my Win98 m/c I also have a file LibUsbWin.dll but this might be
part of the Java driver software

8. By installing my system on a XP machine, I have worked out the answer to my problem. XP tells what files it cannot find and allows you to locate them. The files that cannot be found are libusb0.sys and libusb0.dll even though they are in the system32/driver and system32 folders as required. Pointing the installation routine to these files on another disk allowed the installation to proceed correctly.

So, to Vista. I put the device .inf and .cat files into the system32/inf/other folder. I also copied the 2 libusb0 files into this folder. The Device Driver installation then worked.

EDIT: You may have to optionally edit or run wizard to create an nxt.inf file [see libusb instructions and groups] to point the Device Manager/LEGO''NXT Firmware Update Mode/ properties/driver details to include:
c:\windows\system32\drivers\fantom.sys and c:\windows\system32\drivers\libusb0.sys in the driver file(s) path.

Output of TestLibUsb should look like this for nxt:
DLL version:
Driver version:

bus/device idVendor/idProduct
bus-0/\\.\libusb0-0001--0x03eb-0x6124 03EB/6124
wTotalLength: 67
bNumInterfaces: 2
bConfigurationValue: 1
iConfiguration: 0
bmAttributes: c0h
MaxPower: 0
bInterfaceNumber: 0 ... _id=266688

Please let us know if anyone has any luck with these instructions, and also if they can be simplified.
Last edited by bbagnall on Sun Nov 04, 2007 7:40 pm, edited 1 time in total.

New User
Posts: 2
Joined: Tue Oct 30, 2007 8:15 pm
Location: United Kingdom

Postby ClaireS » Tue Oct 30, 2007 8:46 pm


I have Vista (the 32-bit version) on my laptop and gave these instructions a go (as I too found that trying to run libusb-win32 previously stopped all my USB devices from working). I am glad to say in my case they seem to have done the job perfectly i.e. no USB problems, and I can now both compile and download my code to a NXT and (from what I can tell) it seems to execute ok after... However, I did find I only needed to follow steps 1-3...

Anyway, thanks for these... will definitely make my life much easier, as I can now take the laptop to the robot, instead of the robot to the desktop! :D

User avatar
Site Admin
Posts: 392
Joined: Fri Aug 04, 2006 4:03 pm

Postby bbagnall » Sun Nov 04, 2007 7:42 pm

Thanks for trying that out. I'll update the readme file.

New User
Posts: 1
Joined: Thu Mar 13, 2008 12:35 pm

Postby Robbie » Thu Mar 13, 2008 12:38 pm

I love lejos and now i have to work with vista. So "Thank you ... Thank you ... Thank you. "

Return to “NXJ Software”

Who is online

Users browsing this forum: No registered users and 6 guests