Getting LeJOS to work on OS X 10.9 Eclipse

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: imaqine, 99jonathan, roger

New User
Posts: 1
Joined: Fri Jun 06, 2014 8:50 am

Getting LeJOS to work on OS X 10.9 Eclipse

Postby FairFight » Fri Jun 06, 2014 8:58 am

I am having lots of trouble getting LeJOS to work on OS X 10.9 using Eclipse.
When I run the program via Run -> Run as LeJOS NXT program it gives the following error:

Code: Select all

Linking ...
Error: This Java instance does not support a 32-bit JVM.
Please install the desired version.
Linking the file failed with exit status 1

I have tried to set up the environment to use 32 bit, but cannot get to the work.
I have done so by using the following in .bash_profile:

Code: Select all

export NXJ_HOME="/Users/user/leJOS_NXJ"
export LEJOS_NXT_JAVA_HOME="/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home"
export PATH="$NXJ_HOME/bin:$PATH"

I tried to upload the program via terminal instead of using Eclipse by trying the following:

Code: Select all

samples/src/org/lejos/sample/btreceive $  nxjupload -b
leJOS NXJ> Searching for any NXT using Bluetooth inquiry
dyld: lazy symbol binding failed: Symbol not found: _IOBluetoothLocalDeviceReadSupportedFeatures
  Referenced from: /private/var/folders/t5/yzy4dx_14_91v6ypb2lkv6g80000gn/T/bluecove_user_0/libbluecove.jnilib
  Expected in: /System/Library/Frameworks/IOBluetooth.framework/Versions/A/IOBluetooth

dyld: Symbol not found: _IOBluetoothLocalDeviceReadSupportedFeatures
  Referenced from: /private/var/folders/t5/yzy4dx_14_91v6ypb2lkv6g80000gn/T/bluecove_user_0/libbluecove.jnilib
  Expected in: /System/Library/Frameworks/IOBluetooth.framework/Versions/A/IOBluetooth

/Users/user/leJOS_NXJ/bin/nxjupload: line 78:  1060 Trace/BPT trap: 5       "$JAVA" $NXJ_FORCE32 "-Dnxj.home=$NXJ_HOME" "-DCOMMAND_NAME=$NXJ_COMMAND" -classpath "$NXJ_CP_PC" "$@"

I have read that it is a problem with bluecove.

So my question is: Have anyone got it working on 10.9? I've tried to search the web but could not find any working solution to the problems I stated.

New User
Posts: 14
Joined: Mon Aug 05, 2013 3:28 pm

Re: Getting LeJOS to work on OS X 10.9 Eclipse

Postby dfamil » Wed Jun 18, 2014 3:14 pm


if you want to keep java 1.7 running just add this code to each script, such as nxjbrowse. This works because 1.7 is located in a difference place than 1.6.It seems oracle decided not to conflict with apples last version of java. what is unclear is how long apple will let us use 1.6. LeJOS may have to update these programs 64bit java like the EV3 versions.
add below
# for OSX

export JAVA_HOME="/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/"
export LEJOS_NXT_JAVA_HOME="/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/"
export NXJ_HOME="/Applications/lego/lejos_nxj"
export PATH="$NXJ_HOME/bin:$PATH"

good luck

Return to “NXJ Software”

Who is online

Users browsing this forum: No registered users and 1 guest