Bluetooth BTSend failing

Post your NXJ projects, project ideas, etc here!

Moderators: imaqine, 99jonathan, roger

New User
Posts: 7
Joined: Fri Apr 23, 2010 2:52 am

Bluetooth BTSend failing

Postby jwang » Fri Apr 23, 2010 2:58 am

I'm at the end of my wits. I've been trying to connect with my NXT via bluetooth and it is just not working.

Windows can connect to the device fine over bluetooth, and connecting to the NXT brick and uploading programs using the eclipse plugin is no problem. The only problem is connecting via bluetooth. Everytime I run the samples, I get the following output:

Code: Select all

BlueCove version 2.1.0 on winsock
Failed to connect to any NXT
BlueCove stack shutdown completed

I'm can't connect to it using anything, the nxjbrowse, or the nxjcontrol. I'm not too sure how to debug further. Anyone have any ideas out there?

EDIT: I forgot to mention that my NXT can also see my laptop in the bluetooth menu. The bluetooth power is on, and the visibility setting is on as well.

Also, when I try to upload via Bluetooth, I get the following error:
Exception in open: Open of NXT failed: Connection timeout; [10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Failed to connect to any NXT
Something went wrong when trying to upload the program to the brick

New User
Posts: 19
Joined: Tue Sep 22, 2009 3:44 am

Postby SpikeT » Fri Apr 23, 2010 4:32 am

If the NXT driver was already installed, and the PC can upload the program, I don't see why you can't run the sample program. Also check you battery. It's difficult to connect to the brick sometime when the battery is low.

Try to do these steps:
- delete all Bluetooth hardware profile in the Windows
- delete all program in NXT brick
- try to upload the again. There should be a pop-up window saying that you need to put the security code of the NXT
- run the

New User
Posts: 7
Joined: Fri Apr 23, 2010 2:52 am

Postby jwang » Fri Apr 23, 2010 6:22 am

Thanks for the response, I went through those steps, and still no luck. I've formatted the NXT, reloaded the firmware, and restarted my computer. Still not sure why I can't even use any of the tools like nxjcontrol over bluetooth.

I know bluetooth is working fine on both my laptop and the NXT, as I can see my phone on both, but I'm wondering if there's any configuration I'm missing with the eclipse plugin?

User avatar
leJOS Team Member
Posts: 5972
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Postby gloomyandy » Fri Apr 23, 2010 7:59 am

Your posts are a little confusing as to what is going on so please do the following...
1. Use your OS software on the PC to pair your PC with the NXT (do not pair from the NXT to the PC).
2. Locate and delete any files called nxj.cache on your PC
3. Run the command nxjbrowse (without your NXT connected via USB) from a windows command shell and report back what happens. If it does not work tell us what version of Windows you are running, What Bluetooth stack you are using, and what Bluetooth device you have....


New User
Posts: 7
Joined: Fri Apr 23, 2010 2:52 am

Postby jwang » Fri Apr 23, 2010 5:04 pm

Holy crap, that somehow worked, it seemed like it was just the nxj.cache, as soon as I deleted it, it worked. Thanks so much for your help!

Return to “NXJ Projects”

Who is online

Users browsing this forum: No registered users and 0 guests