lejosjc error

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: imaqine, 99jonathan, roger

New User
Posts: 9
Joined: Wed Sep 05, 2007 9:12 am

lejosjc error

Postby corona » Thu Sep 06, 2007 11:46 am

I have just installed lejos0.4 and managed to compile, download and execute the Tune.java sample program...wooo hooo :)

So I'm off to write my own program in Eclipse, which I set up according to the guidelines in Brian's book.
Upon compilation I got this error
error: cannot read: robots.BehaviourBot.java
1 error

hmm... strange I thought, so I went to the dir where the BehaviourBot.java is located and tried the lejosjc command, which I had just tested could compile the Tune.java program

Now what happens is absolutely nothing!!!! Specifically I don't get the .nxj file I would like... as in the Tune example... does anyone know what is going on?
edit: I just tried to remove the .nxj file from the Tune dir and recompiling using lejosjc.... It doesn't work any longer, and does not produce the .nxj file

This is the output from the prompt:

C:\workspace\lejostest\robots>lejosjc -verbose BehaviourBot.java
[parsing started BehaviourBot.java]
[parsing completed 80ms]
[search path for source files: [.]]
[search path for class files: [C:\Lejos\lejos_nxj\lib\classes.jar, ., C:\Program Files\Jav
a\jdk1.5.0\jre\lib\ext\dnsns.jar, C:\Program Files\Java\jdk1.5.0\jre\lib\ext\localedata.ja
r, C:\Program Files\Java\jdk1.5.0\jre\lib\ext\sunjce_provider.jar, C:\Program Files\Java\j
[loading C:\Lejos\lejos_nxj\lib\classes.jar(lejos/util/TimerListener.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(java/lang/Object.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(lejos/nxt/LightSensor.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(lejos/navigation/Pilot.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(lejos/util/Timer.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(java/lang/String.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(java/lang/Exception.class)]
[checking robots.BehaviourBot]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(lejos/nxt/SensorPort.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(lejos/nxt/ADSensorPort.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(lejos/nxt/LegacySensorPort.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(lejos/nxt/Motor.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(lejos/nxt/BasicMotor.class)]
[loading C:\Lejos\lejos_nxj\lib\classes.jar(java/lang/Throwable.class)]
[wrote BehaviourBot.class]
[total 220ms]

New User
Posts: 9
Joined: Wed Sep 05, 2007 9:12 am

Postby corona » Thu Sep 06, 2007 5:32 pm

Alright, so I shouldn't use lejosjc any longer but NXJC as per the errata.

What's also in the errata is instructions to install the libusb drivers... upon doing that, none of my peripherals connected to usb ports worked any longer... yes mouse and keyboard too

so do I need these device drivers???
we're still under vista here

User avatar
Site Admin
Posts: 392
Joined: Fri Aug 04, 2006 4:03 pm

Postby bbagnall » Sun Sep 09, 2007 6:11 pm

Hi Corona,

What probably happened was the first time you ran LEJOSJC it output a message to the effect that it won't install Lib-USB since it detected Vista. If you had any other version of Windows it would have installed lib-usb automatically.

There is a problem with lib-usb under Vista (see readme for more info). The symptoms you described of losing your USB devices is exactly what we've heard from others.

Lib-USB is a separate Open Source project that we have no control over. You should be able to use Bluetooth no problem, but USB probably won't work properly until they make Lib-USB Vista compatible. My suggestion: send the lib-usb project leaders an email begging for Vista support.

Return to “NXJ Software”

Who is online

Users browsing this forum: No registered users and 4 guests