Problem with Eclipse + Lejos Plugin

This is where you talk about the RCX software itself, installation issues, and programming talk.

Moderator: roger

New User
Posts: 5
Joined: Tue Apr 24, 2007 6:38 pm

Problem with Eclipse + Lejos Plugin

Postby Saxman » Wed Oct 31, 2007 8:31 am


I managed to install the Lejos- Eclipse- Plugins for my Rcx yesterday.
So I was really happy when the firmware download worked. :D

I typed some easy HelloWorld Code and it worked fine. So I tried to do sth. more complicated.
I wrote my own Rcx class and packed it into an own package "rcx". So I have got a package called "rcx" with a class "Rcx". (rcx.Rcx.class).
There is a second class called "Gabler" which extends of "Rcx.class".

I now wrote some test code for my new class and package. Code is ready but there is all the time the same error! :?
I don't know what it means. What am I doing wrong? :?

Link failed due to exception: Error with creating binary closure: Expected java.lang.Object: rcx.Gabler Gabler/src/demo Unbekannt

I hope there is anybody who knows what I am doing wrong. :roll:

Posts: 122
Joined: Thu Mar 01, 2007 5:30 am

Postby 99jonathan » Thu Nov 01, 2007 8:02 am

did you make sure to include Gabler in the rcx package? The compiler apparently simply can not find your

Return to “RCX Software”

Who is online

Users browsing this forum: No registered users and 0 guests