BlueJ plugin

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: imaqine, 99jonathan, roger

New User
Posts: 11
Joined: Thu Jul 05, 2007 1:53 pm
Location: UK

BlueJ plugin

Postby bowser » Thu Sep 13, 2012 8:32 am

I have just updated my Lego LeJOSExtension for BlueJ.

This has solved some of the issues :
1) Windows 7 problems with linking and creating tmp folders
2) nxj shell script overwriting any NXJ_HOME settings in Linux/Mac environments

Tested on Windows (XP & 7), Mac, Linux (OpenSUSE)

The extension can be found at : ... /bluej.php

(An archive of the old extension can be found at ... /bluej.php)

New User
Posts: 1
Joined: Thu Jun 13, 2013 12:34 pm

Re: BlueJ plugin

Postby montero » Thu Jun 13, 2013 12:58 pm

The plugin worked flawlessly until Java updated to 1.7.0_21 on Windows 7. I still can compile and upload by opening a console window, cd'ing to the BlueJ project directory and invoking nxjc.bat and nxj.bat. The error:

"Windows 7

compiling TestPilot

Internal error. The following directory does not exist:
Internal error. The following directory does not exist:
"C:\weg\TestPilot\\..\lib\nxt"Compiling "

"Fatal Error: Unable to find package java.lang in classpath or bootclasspath "

Is there anyone who knows about a workaround - despite using the console window, wich is a solution for me but not for my younger students?

BTW: a friend of mine as a professional programmer with Java told me, that the Java developers decided to change the handling of spaces and umlauts. Is this correct and may this be the reason for the plugin not working any more?


New User
Posts: 1
Joined: Thu Mar 20, 2014 12:13 pm

Re: BlueJ plugin

Postby tbredemeier » Thu Mar 20, 2014 12:17 pm

I'm having the same problem with Windows 7 and BlueJ. Anybody know of a solution?

Return to “NXJ Software”

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 3 guests