Cannot download firmware to RCX, tried firmdl and lejosfirmd

This is where you talk about the RCX software itself, installation issues, and programming talk.

Moderator: roger

New User
Posts: 1
Joined: Sun Mar 23, 2008 12:38 am

Cannot download firmware to RCX, tried firmdl and lejosfirmd

Postby andreyvul » Sun Mar 23, 2008 12:49 am

lejosfirmdl --tty=usb returns with this error:
"write: Resource temporarily unavailable"
firmdl --tty=usb returns with this error:
"Exception in thread "main" java.lang.UnsatisfiedLinkError: ~/lejos_2_1_0/bin/ ~/lejos_2_1_0/bin/ wrong ELF class: ELFCLASS32
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(
at java.lang.ClassLoader.loadLibrary( 1511)
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at josx.rcxcomm.Tower.<clinit>(
OS: Linux 2.6.24 amd64
Java: Blackdown

New User
Posts: 3
Joined: Thu Mar 20, 2008 1:45 am

Postby mahado051 » Mon Mar 31, 2008 3:12 am

i have the same porblem...

i tried to install lejos 3.0

but when i want to execute

mahado@linux:~/Lejos$ firmdl
bash: firmdl: orden no encontrada

and i can't install lejos

i wish that you can help us


User avatar
Posts: 27
Joined: Tue Apr 01, 2008 1:47 pm
Location: United States

Postby JavaMan » Sun Apr 06, 2008 5:37 pm

Looks like to me something is wrong with your lejos classes. Maybe re-download lejos from the site. Also, why are you calling lejofirmdl?

firmdl is the newest command for downloading the firmware.

look up and see the chemtrails

Return to “RCX Software”

Who is online

Users browsing this forum: No registered users and 0 guests