RCX Not responding

This is where you talk about the RCX software itself, installation issues, and programming talk.

Moderator: roger

New User
Posts: 1
Joined: Tue Feb 13, 2007 11:38 am

RCX Not responding

Postby ian_b » Tue Feb 13, 2007 11:41 am

When trying to download the lejos firmware I am recieving an RCX not responding error.

I have tried multiple USB towers and multiple RCXs.

This is using Windows XP. I have tried using cygwin but recieve the noClassDeffinition error so will try to solve that and see if that works.

Any ideas would be great?

New User
Posts: 16
Joined: Fri Feb 09, 2007 5:08 pm

Postby stevendh » Wed Feb 14, 2007 4:18 pm

First thing:

Check that you are in an area that doesn't receive much sunlight, sunlight can truly screw with IR.


The IR tower and RCX brick should be 3-6 inches apart.

Other things to check...

Is the brick running a program? (The firmware cannot download while a prog is running)

Is your RCXTTY environment variable set up correct for the type of communication you are using?

Hope this helps,


Return to “RCX Software”

Who is online

Users browsing this forum: No registered users and 1 guest